Account partner required

by , ,
Odoo          
v 10.0 Third Party 436
Download for 10.0 series Deploy on Odoo.sh
You bought this module and need support ? Click here !
Technical name account_partner_required
LicenseAGPL-3
Websitehttp://acsone.eu/
Read description for v 12.0 v 11.0 v 8.0 v 7.0
Required Apps Invoicing (account)
Included Dependencies
License: AGPL-3

Account Partner Required

This module adds an option Partner policy on account types.

You have the choice between 3 policies:

  • optional (the default policy): partner is optional,
  • always: require a partner,
  • never: forbid a partner.

This module is useful to enforce a partner on account move lines on customer and supplier accounts.

This module is very similar to the module account_analytic_required available in the OCA project account-analytic.

Configuration

Go to the menu Accounting > Configuration > Accounting > Account Types and edit each account types to configure the correct Partner policy.

Usage

If you put a partner on an account move line with an account whose type is configured with Partner policy = never, you will get an error message.

If you don't put a partner on an account move line with an account whose type is configured with Partner policy = always, you will get an error message.

Try me on Runbot

Bug Tracker

Bugs are tracked on GitHub Issues. In case of trouble, please check there if your issue has already been reported. If you spotted it first, help us smashing it by providing a detailed and welcomed feedback.

Credits

Contributors

Maintainer

Odoo Community Association

This module is maintained by the OCA.

OCA, or the Odoo Community Association, is a nonprofit organization whose mission is to support the collaborative development of Odoo features and promote its widespread use.

To contribute to this module, please visit https://odoo-community.org.

Please log in to comment on this module

Please choose a rating from 1 to 5 for this module.