v 10.0 v 11.0 Third Party 1846
Download for 10.0 series Deploy on Odoo.sh
Required Apps Website Builder (website)
Technical Name website_multi_theme
LicenseLGPL-3
Websitehttps://www.tecnativa.com
Also available in version v 11.0 v 10.0
You bought this module and need support? Click here!
License: LGPL-3

Website Multi Theme

Allow the website admin to set a different theme for each website.

The theme might be not just a theme-module, but any set of themes and even particular views from any module (e.g. view website.custom_footer from website module). It also means, that theme is not just a styling, but a content as well.

How it works

Core idea is as following

  • Find views created by theme-module and mark them as multi-views (website.theme.asset) additionally to one specified manually via XML (see demo/themes.xml as an example). The method _convert_assets is responsible for it.
  • Set active to False for multi-views. See method _find_and_deactivate_views.
  • Apply Multi-theme (record in new model website.theme) to the specific website. See method _multi_theme_activate
    • Make some magic with technical views website.assets_frontend and website.layout.
      • Duplicate patterns from templates/patterns.xml
      • In layout_pattern replace {theme_view} placeholder to a duplicate of assets_pattern
      • Corresponding duplicated pattern will be used as a new value for inherit_id field in duplicated multi-views that originally extend web.assets_frontend, website.assets_frontend or website.layout.
    • Duplicate multi-views of the multi-theme and its dependencies (other multi-themes). In duplicates, the field inherit_id is changed to other duplicated views or duplicated patterns when possible

Installation

To make this module work, you need to either:

  • Install any of the officially supported themes:
    • theme_bootswatch
  • Install any of the unofficially supported themes (at your own risk):
    • theme_anelusia
    • theme_artists
    • theme_avantgarde
    • theme_beauty
    • theme_bewise
    • theme_bistro
    • theme_bookstore
    • theme_clean
    • theme_enark
    • theme_graphene
    • theme_kea
    • theme_loftspace
    • theme_mongolia
    • theme_nano
    • theme_notes
    • theme_odoo_experts
    • theme_orchid
    • theme_treehouse
    • theme_vehicle
    • theme_yes
    • theme_zap

Themes in the above lists will become multiwebsite when installed along this module. If they get installed after ``website_multi_theme``, update this module manually, or it will not be notified of such change.

Configuration

To configure this module, you need to:

  1. Go to Website Admin > Configuration > Settings and choose or create
    a Website.
  2. Press Advanced > Multiwebsite theme > Reload.
  3. In Advanced > Multiwebsite theme, pick one of the available themes.

Once you save, any website that has no Multiwebsite theme selected will have, the default plain Bootstrap theme, and those that do have one will get it.

Of course, your Odoo instance must be reachable by all of the provided host names, or nobody will ever see the effect. But that is most likely configured through your DNS provider and/or proxy, so it is not a matter of this addon.

If you want to test this behavior, think that localhost and 127.0.0.1 are different host names.

Usage

To use this module, you need to:

  1. Follow the configuration steps.
  2. Enter any of the websites you modified.
Try me on Runbot

Development FAQ

How to develop a multiwebsite-ready theme?

Check demo/themes.xml. It includes a demo theme that will serve as a template for you. This demo theme turns primary buttons green, so you can test if it is applied or not easily.

How to convert a single-website theme in a multi-website one?

Check data/themes_bootswatch.xml. You must do that. You can consider adding the support directly in this addon, given it will just do nothing if the single-website theme addon is not installed (it acts as a soft dependency).

How to get multiwebsite-specific views updated?

This addon is conservative by default, meaning that in production databases views will not be updated if they already were created (except for the ones copied from templates/patterns.xml).

To force your website getting updated views for all views from a base theme that has changed, you should disable the website multi theme (to make the engine remove all views) and then re-enable it again (to recreate them from scratch).

This does not happen in demo or development instances, where views arch is always updated.

Known issues / Roadmap

Credits

Contributors

Maintainer

Odoo Community Association

This module is maintained by the OCA.

OCA, or the Odoo Community Association, is a nonprofit organization whose mission is to support the collaborative development of Odoo features and promote its widespread use.

To contribute to this module, please visit https://odoo-community.org.

Please log in to comment on this module

  • The author can leave a single reply to each comment.
  • This section is meant to ask simple questions or leave a rating. Every report of a problem experienced while using the module should be addressed to the author directly (refer to the following point).
  • If you want to start a discussion with the author, please use the developer contact information. They can usually be found in the description.
Please choose a rating from 1 to 5 for this module.
Cannot install module
by
Chandni
on 1/24/18, 8:10 AM

Unable to install module "website_multi_theme" because an external dependency is not met: Unable to find 'sass' in path Can anyone here to help_?


For issue related to 'sass' in path
by
Purnendu Singh
on 8/1/18, 10:55 AM

Just for reference: Try these steps to install external dependencies Firstly install the external dependencies: apt-get install ruby-compass gem install compass bootstrap-sass


I can't install this module it shows the following error message "Unable to install module "website_multi_theme" because an external dependency is not met: Unable to find 'sass' in path"
by
Tung
on 7/5/18, 8:32 PM

I can't install this module it shows the following error message "Unable to install module "website_multi_theme" because an external dependency is not met: Unable to find 'sass' in path"


worried
by
karniz
on 10/2/17, 8:51 AM

I can't install this module it shows the following error message "Unable to install module "website_multi_theme" because an external dependency is not met: Unable to find 'sass' in path"